man : afsd.conf(5)
AFSD.CONF(5) OpenBSD Programmer's Manual AFSD.CONF(5)
afsd.conf - configuration file for the arla AFS implementation.
The default configuration file works very well in most cases.
Most flags can be overridden by command line arguments to afsd.
Each option can be of the type integer, string or boolean.
Integer values can be written with suffix `K' (kilo, 1000), `M' (mega,
10000000) and `G' (giga, 10000000000) .
Strings are written without quotes or spaces in the strings.
Boolean values can be either of yes, true, no, or false.
Boolean value. Dynamic root, generates your /afs directory from
CellServDB or DynRootDB. Useful when you don't want to use your
Boolean value. If set, do not fetch real stat information where
it can be expensive (i e across mountpoints), but make up some
Integer value. Determines the fetch/pre-fetch block size. This
option will later be replaced by code to automagically tune this
Integer value. The number of used vnodes we try to keep in the
cache. Any higher number of used nodes will trigger the cleaner
Integer value. The high watermark for files used by arlad.
Integer value. The number of bytes we try to keep in the cache.
Any higher number of bytes will trigger the cleaner thread.
Integer value. The maximum number of credentials kept in arla,
both authenticated (like Kerberos V4 creds), and not.
Integer value. The maximum total number of connections arla will
keep to servers (fileserver and vldb-server).
Integer value. The number of volumes stored in cache.
String value. The sysname is possible to specify in the
configuration file. It's overridden by the command line argument
--sysname=sysname to arlad.
It can be one of: clear, auth, or crypt. It's the same as the
command line argument.
Integer value. The upper limit of arlad's vnodes (think files
The parser that reads numbers doesn't support numbers larger than 2G for
most platforms when used on the abbreviated form (3G, 3000M, etc). Write
out the whole number (3000000000) and make sure you have a working
AliasDB(5), CellServDB(5), DynRootDB(5), ThisCell(5), afsd(8)
The Arla Project September 9, 2000 The Arla Project