man : halt(8)
REBOOT(8) OpenBSD System Manager's Manual REBOOT(8)
reboot, halt - stopping and restarting the system
The halt and reboot utilities flush the file system cache to disk, run
the system shutdown script, send all running processes a SIGTERM (and
subsequently a SIGKILL), and, respectively, halt or restart the system.
The action is logged, including entering a shutdown record into the login
The options are as follows:
-d Causes system to create a dump before rebooting. This option is
useful for debugging system dump procedures or capturing the
state of a corrupted or misbehaving system. See savecore(8) for
information on how to recover this dump.
-n Prevent file system cache from being flushed. This option should
probably not be used.
-p Causes the system to power down, if it is being halted, and the
hardware supports automatic power down.
See also the description of powerdown, below.
-q Quick. The system is halted or restarted quickly and
ungracefully, and only the flushing of the file system cache is
performed. This option should probably not be used.
Normally, the shutdown(8) utility is used when the system needs to be
halted or restarted, giving users advance warning of their impending
/etc/rc.shutdown Script which is run at shutdown time. If it sets the
variable powerdown to ``YES'', halt will attempt to
power down the machine after it has halted.
reboot(2), utmp(5), boot_alpha(8), boot_amd64(8), boot_hp300(8),
boot_hppa(8), boot_hppa64(8), boot_i386(8), boot_luna88k(8),
boot_mac68k(8), boot_macppc(8), boot_mvme68k(8), boot_mvme88k(8),
boot_sparc(8), boot_sparc64(8), boot_vax(8), boot_zaurus(8),
rc.shutdown(8), savecore(8), shutdown(8), sync(8)
A reboot command appeared in Version 6 AT&T UNIX.
OpenBSD 4.9 November 19, 2007 OpenBSD 4.9