man : intro(4)
INTRO(4) OpenBSD Programmer's Manual (AMD64) INTRO(4)
intro - introduction to special files and hardware support
The manual pages in section 4 describe the special files, related driver
functions, and networking support available in the system. In this part
of the manual, the SYNOPSIS section of each configurable device gives a
sample specification for use in constructing a system description for the
config(8) program. The DIAGNOSTICS section lists messages which may
appear on the console and/or in the system error log /var/log/messages
due to errors in device operation; see syslogd(8) for more information.
This section contains both devices which may be configured into the
system and network related information. The networking support is
introduced in netintro(4).
This section describes the hardware supported on the amd64 platform.
Software support for these devices comes in two forms. A hardware device
may be supported with a character or block device driver, or it may be
used within the networking subsystem and have a network interface driver.
Block and character devices are accessed through files in the file system
of a special type; see mknod(8). Network interfaces are indirectly
accessed through the interprocess communication facilities provided by
the system; see socket(2).
A hardware device is identified to the system at configuration time and
the appropriate device or network interface driver is then compiled into
the system. When the resultant system is booted, the autoconfiguration
facilities in the system probe for the device and, if found, enable the
software support for it. If a device does not respond at
autoconfiguration time it is not accessible at any time afterwards. To
enable a device which did not autoconfigure, the system will have to be
The autoconfiguration system is described in autoconf(4).
LIST OF DEVICES
A complete list of available devices is contained within the pages
describing the system buses and controllers. For example, a PCI device
would be listed in the pci(4) man page. The following buses and
controllers list these devices:
cardbus(4) introduction to CardBus support
eisa(4) introduction to EISA bus support
iic(4) Inter IC (I2C) bus
isa(4) introduction to ISA bus support
isapnp(4) introduction to ISA Plug-and-Play support
onewire(4) 1-Wire bus
pci(4) introduction to PCI bus support
pcmcia(4) introduction to PCMCIA (PC Card) support
usb(4) introduction to Universal Serial Bus support
autoconf(4), cpu(4), config(8)
The amd64 intro first appeared in OpenBSD 3.5.
OpenBSD 4.9 October 9, 2007 OpenBSD 4.9