man : intro(8)
INTRO(8) OpenBSD System Manager's Manual INTRO(8)
intro - introduction to system maintenance and operation commands
The manual pages in section 8 contain information related to system
operation and maintenance. They describe commands concerning file
systems, such as edquota(8), fsck(8), mount(8), and newfs(8). They also
cover commands concerning system backup/recovery, such as dump(8) and
There are pages which document the running of the system, such as
afterboot(8), ifconfig(8), security(8), and the configuration files
located in /etc. Procedures concerning system failure are documented in
Section 8 pages also describe network services and daemons. The rest of
this page discusses some of the main daemons available on the OpenBSD
system, and how to enable/disable them.
System daemons are controlled by the script rc(8), which is in turn
configured by rc.conf(8). For example the HTTP daemon httpd(8) is
controlled by the following line from rc.conf(8):
Thus it is not started by default. To enable or disable daemon
processes, administrators should edit the file rc.conf.local(8), which
overrides rc.conf(8). So to enable httpd(8), the following line might be
added to /etc/rc.conf.local:
As can be seen above, this method is also used to specify additional
Below is a list of some of the daemons available. For further
information, see rc(8) and the individual pages for the utilities.
Apache web server (HTTP)
The apache web server, httpd(8). On OpenBSD, it will chroot(2) to the
``ServerRoot'' path. Detailed information is available in
Relevant rc.conf(8) variables: httpd_flags.
Automounter daemon (amd)
If using the amd(8) package, go into the /etc/amd directory and set it up
by renaming master.sample to master and editing it and creating other
maps as needed. Alternatively, you can get your maps with YP.
Relevant rc.conf(8) variables: amd, amd_dir, and amd_master.
BIND name server (DNS)
If you are using the BIND name server, check the /etc/resolv.conf file.
It may look something like:
search nts.umn.edu. umn.edu.
lookup file bind
If using a caching name server, add the line "nameserver 127.0.0.1"
Relevant rc.conf(8) variables: named_flags.
In order to make sure the system clock is correct, it may be synchronised
with a number of external sources. The utilities available are: ntpd(8),
rdate(8), and timed(8).
Relevant rc.conf(8) variables: ntpd_flags, rdate_flags, and timed_flags.
Concatenated disks (ccd)
If you are using ccd(4) concatenated disks, edit /etc/ccd.conf. Use the
ccdconfig -U command to unload and the ccdconfig -C command to create
tables internal to the kernel for the concatenated disks. You then
mount(8), umount(8), and edit /etc/fstab as needed.
If this is a BOOTP or DHCP server, edit /etc/dhcpd.conf as needed. See
Relevant rc.conf(8) variables: bootparamd_flags, dhcpd_flags, and
HP remote boot server
Edit /etc/rbootd.conf if needed for remote booting. If you do not have
HP computers doing remote booting, do not enable this. See also
Relevant rc.conf(8) variables: rbootd_flags.
If you are going to use kerberos(8) for authentication, and you already
have a Kerberos master, change directory to /etc/kerberosV and configure.
Remember to get a srvtab from the master so that the remote commands
Relevant rc.conf(8) variables: krb5_master_kdc and krb5_slave_kdc.
If this is an NFS server, edit /etc/exports.
Relevant rc.conf(8) variables: nfs_server and nfsd_flags.
A relay daemon, relayd(8), able to run as a load-balancer, application
layer gateway, or transparent proxy.
Relevant rc.conf(8) variables: relayd_flags.
Various daemons for managing routing tables are available: bgpd(8),
ospfd(8), and ripd(8).
Relevant rc.conf(8) variables: bgpd_flags, ospfd_flags, and ripd_flags.
RPC-based network services
Several services depend on the RPC portmapper, portmap(8), being running
for proper operation. This includes YP and NFS exports, among other
Relevant rc.conf(8) variables: portmap.
Check the YP domain name with the domainname(1) command. If necessary,
correct it by editing the /etc/defaultdomain file (see defaultdomain(5)).
The /etc/netstart script reads this file on boot to determine and set the
domain name. You may also set the running system's domain name with the
domainname(1) command. To start YP client services, simply run ypbind,
then perform the remaining YP activation as described in passwd(5) and
In particular, to enable YP passwd support, you'll need to add the
following line to /etc/master.passwd:
You do this by using vipw(8).
There are many more YP man pages available to help you. You can find
more information by starting with yp(8).
afterboot(8), rc(8), rc.conf(8)
The intro section manual page appeared in 4.2BSD.
OpenBSD 4.9 February 18, 2010 OpenBSD 4.9