man : ppp(4)
PPP(4) OpenBSD Programmer's Manual PPP(4)
ppp - Point-to-Point Protocol network interface
The ppp interface allows serial lines to be used as network interfaces
using the Point-to-Point Protocol (PPP).
A ppp interface can be created at runtime using the ifconfig pppN create
command or by setting up a hostname.if(5) configuration file for
The ppp interface can use various types of compression and has many
advantages over the SLIP protocol used by the sl(4) interface.
ppp%d: af%d not supported The interface was handed a message with
addresses formatted in an unsuitable address family; the packet was
inet(4), sl(4), hostname.if(5), ifconfig(8), netstart(8), pppd(8),
The Point-to-Point Protocol (PPP), RFC 1661, July 1994.
The ppp device appeared in OpenBSD 1.2.
Currently, only the ip(4) protocol is supported.
OpenBSD 4.9 January 31, 2009 OpenBSD 4.9