man : sasyncd.conf(5)
SASYNCD.CONF(5) OpenBSD Programmer's Manual SASYNCD.CONF(5)
sasyncd.conf - configuration file for sasyncd
sasyncd.conf is the configuration file for the sasyncd(8) daemon.
Comments can be put anywhere in the file using a hash mark (`#'), and
extends to the end of the current line.
Since the file contains the shared secret key used to encrypt data
between this host and the others, /etc/sasyncd.conf must be owned either
by ``root'' or the ``_isakmpd'' pseudo user and be readable only by this
# chown root /etc/sasyncd.conf
# chmod 0600 /etc/sasyncd.conf
The following configuration settings are understood:
Specify which carp(4) interface sasyncd(8) should track
master/slave state on.
Specify on which interface group sasyncd(8) should increase the
demote counter. This has the effect of suppressing carp(4)
preemption while initial sasyncd(8) state is established. The
default is to use the ``carp'' group.
For more information on interface groups, see the group keyword
flushmode sync | startup | never
Controls how the sasyncd(8) master host handles SADB_FLUSH
messages to its slaves.
sync Pass any SADB_FLUSH messages along. For
example, in this mode sasyncd(8) will
synchronize an ipsecctl -F command to all
connected slaves. For more information, see
startup Send a SADB_FLUSH message to the slaves as they
connect, and act as sync afterwards. This is
never Never send SADB_FLUSH messages.
listen on address [family] [port port]
Specify a local IP address, hostname, or interface the sasyncd(8)
daemon should listen on. The default is to listen on all local
addresses. When using an interface name, family may be given as
``inet'' or ``inet6'' to only bind using the specified address
family. Finally, port can be used to specify which TCP port
sasyncd(8) should listen to. The default is to listen to port
mode master | slave
Force the daemon to run as master or slave. Normally only
intended for debugging use.
Prevent the daemon from syncing SA or SPD messages where the
source or destination address is one of the configured peers.
Intended to permit IPsec pfsync(4) protection. This mode is
Specify a sasyncd(8) peer IP address or hostname. May be
specified multiple times. For example:
The shared AES key used to encrypt messages between sasyncd(8)
hosts. This configuration setting is required and must be either
16, 24 or 32 bytes long (corresponding to AES using a 128, 192 or
256 bit key).
control isakmpd | iked | all | none
By default, sasyncd(8) tracks its local master/slave mode and
toggles the passive mode of isakmpd(8) accordingly. This option
can be changed to control iked(8) instead, to control all
supported daemons at the same time, or to turn it off to
synchronize SAs only.
chmod(1), carp(4), chown(8), ipsecctl(8), sasyncd(8)
The sasyncd.conf file format first appeared in OpenBSD 3.8.
OpenBSD 4.9 June 30, 2010 OpenBSD 4.9