man : yp(8)
YP(8) OpenBSD System Manager's Manual YP(8)
yp - description of the YP subsystem
ypinit -m [domainname]
ypinit -s master_server [domainname]
ypinit -u [domainname]
ypbind [-insecure] [-ypset] [-ypsetme]
ypset [-d domain] [-h host] server
yppoll [-d domain] [-h host] mapname
ypcat [-kt] [-d domainname] mapname
ypmatch [-kt] [-d domainname] key ... mapname
ypwhich [-t] [-d domain] [[-h] host]
ypwhich [-t] [-d domain] [-h host] -m [mname]
ypserv [-1dx] [-a aclfile]
ypxfr [-cf] [-C tid prog ipadd port] [-d domain] [-h host] [-s domain]
yppush [-v] [-d domainname] [-h hostname] mapname
rpc.yppasswdd [-nogecos] [-nopw] [-noshell] [-d directory] [-m arg ...]
The YP subsystem allows network management of passwd, group, and hosts
file entries through the functions getpwent(3), getgrent(3) and
gethostbyname(3). A number of other databases can be network-managed as
well, and have their respective functions. YP also provides hooks for
numerous other client programs such as amd(8) and bootparamd(8) to access
distributed and shareable versions of their maps through YP. The YP
subsystem requires that portmap(8) be running, since the entire subsystem
uses the RPC subsystem.
ypinit is used to initialize YP as a master or a slave. This creates
various files in /var/yp. After running ypinit -m, optionally edit
/var/yp/DOMAINNAME/Makefile to change settings, for example to switch
from the default backwards compatible mode to secure mode. Finally,
always run make(1) in /var/yp. See Makefile.yp(8) for details.
If set up as a slave, the required databases are automatically copied
from the specified server.
The YP client subsystem is started automatically in /etc/rc if the
directory /var/yp/binding exists. The client subsystem can be turned on
and off by creating or deleting that directory. ypbind(8) will create
that directory if run by hand.
The YP server subsystem is started automatically in /etc/rc if the
directory /var/yp/DOMAINNAME exists. This directory is automatically
created by ypinit(8) (which initializes the machine as a YP server).
If ypbind cannot find a server, the system behaves the same way as Sun's
code does: it hangs.
/var/yp/Makefile.main Top level YP Makefile
/var/yp/Makefile.yp YP maps Makefile
domainname(1), ypcat(1), ypmatch(1), ypwhich(1), ypclnt(3),
defaultdomain(5), group(5), passwd(5), resolv.conf(5), Makefile.yp(8),
portmap(8), rpc.yppasswdd(8), ypbind(8), ypinit(8), yppoll(8), yppush(8),
ypserv(8), ypset(8), ypxfr(8)
This free YP subsystem is thought to be compatible with Sun's
implementation. It is, of course, not compatible with NIS+ or any other
``secure'' YP subsystem other than the native one.
The name YP stands for Yellow Pee.
The ypbind, most library components, and userland programs were
implemented by Theo de Raadt <deraadtATtheos.com>. The current
getpwent(3) implementation was done by Jason Downs <downsjATdownsj.com>.
The server component was implemented by Mats O Jansson
OpenBSD 4.9 April 5, 2009 OpenBSD 4.9